Welcome

My Screen Capture ActiveX

More information at: http://www.namtuk.com

This control let you capture screen in 5 ways (Full screen, Active window, predefined region, manual region and specific window) and getting instant result in memory. Some options are available to save the screen on disk and/or send it to clipboard.
Easy to use, one of the good scenario is that you can add new support feature to your application by adding screen shot capture for user report when a problem appear.
Source Code available for purchase.

CLSID :{E579D6D6-7561-4F80-B4ED-5E47C11B7976}

Version History :

Version 1.20 from April 14, 2005
- ADDED: Possibility to add a capture region (new property UseRegion) with capture methods 'CaptureActiveWindows' and 'CaptureSpecificWindows'.

Version 1.10 from April 8, 2005
- IMPROVED: Can now capture the layered windows (like a transparent window).

Version 1.01 from November 18, 2004
- Fixed: bug corrected when using the method CaptureActiveWindow.

Version 1.00 from September 24, 2004
- Official release.

(c) Namtuk


Order this product

How to order this product

More information at: http://www.namtuk.com

You can purchase this product by going into our web site: www.namtuk.com .

The order process is available in many languages: ENGLISH, FRENCH, SPANISH, DEUTSCH, PORTUGUES, ITALIANO..., you can also purchase with credit card, cash, check, wire transfer, Switch/Solo... just take a look, and if you need more informations you have a full order FAQ available on the web page.

Don't forget you can also purchase the full application source code.
(c) Namtuk


License

License information

More information at: http://www.namtuk.com

Product: My Screen Capture ActiveX

MyScreenCapture is developed and published by Namtuk Software. You may use it for development with Microsoft Visual Studio 6.0, .NET, and any other programming environment supporting ActiveX like PowerBuilder, NetCobol, Real basic,....

You may also distribute the following control files, royalty free, with any application you develop:

MyScreenCapture.ocx

End-users of your applications are not licensed to use MyScreenCapture for development, and may not redistribute any of the above control files.

You are not licensed to distribute any MyScreenCapture file to users for development purposes. You are not allowed to add or transfer the MyScreenCapture license key to the registry of your users' computer(s).

In particular, if you create a control using a MyScreenCapture as a constituent control, you are not licensed to distribute the control you created with the MyScreenCapture to users for development purposes.

By purchasing the source code, you can use it, update it, and include it in your own application, but you are not authorized to share or resell the source code.

It is your responsibility to make such restrictions clear to your users.

Please support and respect the work!

Groups of multiple developers may be interested in acquiring this product for site licenses. Please contact us for details.

(c) Namtuk


How to contact us

More information at: http://www.namtuk.com

You can contact us by connecting to our web site www.namtuk.com and use the contact form to ask us any questions.

(c) Namtuk


Redistributable files

How to distribute the control in your application

More information at: http://www.namtuk.com

You may use My Screen Capture ActiveX for development with Microsoft Visual Studio or any other programming environment supporting ActiveX. You may also distribute the following control files, royalty free, with any application you develop:

MyScreenCapture.ocx

This control is a VB6 runtime dependency and if your application will run on Windows 95, windows 98(first edition) and Windows NT4, you need to install also the VB6 runtime, for other systems (like Windows XP, ME, ..., you don't need it). You can find the MSVBVM60 package on our web site, or on Microsoft web site, it is also available as a MSI package for your setup.

IMPORTANT: When you create setup for shipping your applications, make sure you use a professional installation utility such as the InstallShield, Wise Installation System, or the setup wizard that ships with Microsoft Visual Studio.

For people wh are looking for the GUI number to use in in HTML/ASP/../ :

CLSID :{E579D6D6-7561-4F80-B4ED-5E47C11B7976}

(c) Namtuk


Filename property (MyCapture)

Returns/sets filename to save capture if you have set property SendToDisk at true. It can be only BMP file format and you have to include the full path (for example: c:\mycapture.bmp). To save picture in another format like JPEG, you have to use an external dll, contact us for more information.

Property type

A String value.

Syntax

object.Filename [= value]

The Filename property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MyCapture.
value | A String value.


RegionHeight property (MyCapture)

Returns/sets height in pixel of the region to capture when using the method CaptureRegionAuto , CaptureActiveWindows and CaptureSpecificWindows .

Property type

A Integer value.

Syntax

object.RegionHeight [= value]

The RegionHeight property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MyCapture.
value | A Integer value.


RegionWidth property (MyCapture)

Returns/sets width in pixel of the region to capture when using the method CaptureRegionAuto , CaptureActiveWindows and CaptureSpecificWindows .

Property type

A Integer value.

Syntax

object.RegionWidth [= value]

The RegionWidth property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MyCapture.
value | A Integer value.


RegionX property (MyCapture)

Returns/sets position X in pixel of the region to capture when using the method CaptureRegionAuto , CaptureActiveWindows and CaptureSpecificWindows .

Property type

A Integer value.

Syntax

object.RegionX [= value]

The RegionX property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MyCapture.
value | A Integer value.


RegionY property (MyCapture)

Returns/sets position Y in pixel of the region to capture when using the method CaptureRegionAuto , CaptureActiveWindows and CaptureSpecificWindows .

Property type

A Integer value.

Syntax

object.RegionY [= value]

The RegionY property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MyCapture.
value | A Integer value.


SendToClipboard property (MyCapture)

Returns/sets if capture is also copied to clipboard.

Property type

A Boolean value.

Syntax

object.SendToClipboard [= value]

The SendToClipboard property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MyCapture.
value | A Boolean value.


SendToDisk property (MyCapture)

Returns/sets if capture is saved to disk. Make sure you have specified a filename .

Property type

A Boolean value.

Syntax

object.SendToDisk [= value]

The SendToDisk property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MyCapture.
value | A Boolean value.


Version property (MyCapture)

Returns the current control version.

Property type

A String value.

Syntax

object.Version [= value]

The Version property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MyCapture.
value | A String value.


UseRegion property (MyCapture)

Enable/Disable the use of region properties to capture when using the methods CaptureActiveWindows and CaptureSpecificWindows.
When you capture for example the active window, you can capture only a portion inside it, just define the regions.

Property type

A Boolean value.

Syntax

object.UseRegion [= value]

The UseRegion property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MyCapture.
value | A Boolean value.


CaptureActiveWindows method

This function capture the current active Windows (application which have the focus).
Now, you can capture only a region in the active window, just use the regions properties and set the UseRegion to true.

Return Type

A Picture value.


CaptureFullScreen method

This function capture the full current screen.

Return Type

A Picture value.


CaptureRegionAuto method

This function capture the screen with the current parameters: RegionX, RegionY, RegionWidth and RegionHeight.

Return Type

A Picture value.


CaptureRegionManual method

This function open the manual mode which enable the user to capture the current screen by clicking with left mouse button and move the mouse to select the region. User can also press keyboard key ESC to cancel operation.

Return Type

A Picture value.


CaptureSpecificWindows method

By giving in function parameter the HWND of Windows, it will capture it automatically. This function is great if you need to send application report to your technical support after a bug or a user request.
Now, you can capture only a region in the active window, just use the regions properties and set the UseRegion to true.

Return Type

A Picture value.


Error event

This event return an eventual error string.

Syntax

Sub object_Error(Description As String)

The Error event syntax has these named arguments:

Part | Description
Description | String